Home Forums Product Support Novella Creating a Static Front Page

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #4183
    UConn MAGIC
    Participant

    Hi folks,

    I am having an issue creating a static front page. I did see another similar topic about this but the issue was slightly different and has already been marked as Resolved. I go to Appearance > Customize > Static Front Page, and underneath Front Page Displays click the radio button for A Static Page (the other choice is “Your Latest Posts”). At this point, two links show up underneath: Front Page and Posts Page. The cursor changes to a hand pointer over both of these, indicating I should be able to click on them, however when I click, nothing happens. After saving and closing, no apparent changes seem to have been made on the front of the site and the “front page” continues to display all of my posts.

    I also tried creating a few Pages and editing their attributes (whether Default, Gallery, or Page) and their order, but this does not seem to change anything either.

    Can someone help me figure out what I am missing? Thanks!!

    • This topic was modified 7 years, 2 months ago by UConn MAGIC.
    #4185
    Hyun Supul
    Keymaster

    Hiya! Sorry to hear you’re having troubles. WordPress provides those controls so it’s easy to set within customizer, however, you can also set them within Settings–>Reading within WordPress admin area. Are you able to set and save it there?

    #4186
    UConn MAGIC
    Participant

    Hi Nick, thanks for your quick response! The only options available to me in Settings > Reading are

    Blog pages show at most __ posts
    Syndication feeds show the most recent __ items
    For each article in a feed show Full Text or Summary
    Search Engine Visibility

    so this doesn’t appear to solve my issue. Just wondering how to create the front page, and then tell Novella that is the page to use.

    #4187
    Hyun Supul
    Keymaster

    That is really odd. So just to clarify you are not seeing the top part that allows you to set the front page? Just curious are you up to date with WordPress? Current is 4.0.

    http://cl.ly/image/2J1v0K2C3y0e

    #4188
    UConn MAGIC
    Participant

    Nick – thanks for your help before. I figured out the issue. All of the pages that I currently had were Privately published. As a result, the “Front Page” and “Posts Page” options under Appearance > Customize > Static Front Page had no pages to choose from. I changed some of the privately published pages to public, and dropdown menus appeared under each of the categories.

    #4189
    Hyun Supul
    Keymaster

    Oh awesome to hear! That would completely make sense. So happy that you’ve got it figured out, and be sure to submit your site to the showcase! We love seeing what folks are doing.

    http://aesopstoryengine.com/showcase

    #4190
    UConn MAGIC
    Participant

    Nick – correct. The “Front Page” option was not available in Settings > Reading when all of my pages were published privately. As soon as I changed one of the pages to Public, then the Front Page option became available in Settings > Reading, and the dropdown menus appeared as previously mentioned! Interesting. Thanks for your help! (And am using WordPress 3.9.2)

    #4215
    Jenny @ Aesop
    Keymaster

    Thanks so much for letting us know this is resolved. We’re always here to help!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.