Home Forums ASE Support Mapbox Input field disabled

This topic is: resolved
Viewing 6 posts – 1 through 6 (of 6 total)
  • Author

    Posts

  • #14662

    Reply

    team_arkham

    Participant

    Hi there!

    I have currently the issue that I cannot enter any coordinates or city names into the map as the field somehow seems disabled. See screenshot: Screenshot with disabled map input

    I did also try to create a new mapbox id, but as already mentioned in a different thread (http://aesopstoryengine.com/topic/mapbox-mapid-map-not-loading/) mapbox seems to relaunched and I think their approach changed as all I get are tokens and not mapbox id’s.

    Can anyone help?

    Many thanks in advance!

    #14663

    Reply

    Hyun Supul

    Keymaster

    Hi I will release a new version of ASE sometime next week to address this. In short, you need a Google API key that you can here:
    https://developers.google.com/maps/documentation/javascript/get-api-key

    I will release a new version of ASE that would let you use your API key

    #14673

    Reply

    Hyun Supul

    Keymaster

    Hi try the newest ASE version 1.9.6.3

    The new version uses Google Map API Key. While a default key is supplied, it’s recommended you obtain your own API key for your website. Go to Dashboard->Appearance->Customize->Aesop Story Engine and follow the instruction.

    #14688

    Reply

    team_arkham

    Participant

    Hi! This is great thanks a lot!!!

    Unfortunately there is a little bug in the new update, in the file “component-map.php” on Line 40 is:
    $goog_apikey = get_option( 'ase_mapbox_id' );
    instead of
    $goog_apikey = get_option( 'ase_mapbox_apikey' );

    so it actually tries to send the mapbox id instead of the analytics key.

    #14689

    Reply

    Hyun Supul

    Keymaster

    Hi, my bad and THANK YOU SO MUCH for your sharp eyes!. I am releasing a new version (1.9.6.4) right now and should be available soon.

    Hyun

    #17364

    Reply

    Mark Trepanier

    Participant

    I’m having the same issue as the screenshot shown in the first post. Initially, the map allowed for entering the coordinates / city name, but after inserting my own API, I lost this ability. Is there something more I need to do when creating the map API? Thank you for any help with this.

Viewing 6 posts – 1 through 6 (of 6 total)
Reply To: Mapbox Input field disabled