Home Forums Product Support Novella Problem with components

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3815
    Sophie Marteau
    Participant

    Hello! I have a lot of problem when I’m adding content and quote components.
    For example, I would like my quote background color to be “#7a7a7a” and my text to be #a982fc. So I pick up the colors in the color editor then when I valid it, this is what is written in the post:

    [aesop_quote width=”1200px” background=”#7a7a7a” text=”#a982fc” align=”center” size=”2″ parallax=”off” direction=”up” quote=”Vous trouverez dans les pages ci-dessous quelques considérations valdinguées, tirées de la presse, de livre ou simplement personnelles sur des thèmes qui vont de la politique à l’écologie en passant par la taule, la spiritualité …”]

    It sound all right BUT when I see the page in my computer, the background color is the story accent color I choosed and not the #7a7a7a I wanted.

    I have the same problem with content components: I tried to put a color for the background but it doesn’t appear when I see it in my browser…the background is transparent…

    Do you have any idea how to solve this?

    Thanks in advance.
    Sophie

    #3817
    Jenny @ Aesop
    Keymaster

    Hi Sophie. Thanks for posting!

    Edited: See below.

    #3824
    Jenny @ Aesop
    Keymaster

    Hi Sophie. I wanted to follow up on this after speaking with the developers.

    The text color and background color options are not supposed to alter anything in Novella. It is the designer’s intention to have a static color scheme throughout the theme (this is documented in your owner’s manual).

    If you wish to change the look, you may alter the link color and accent color via WPadmin –> Appearance –> Customize –> Novella Options. Aside from that, you may also change whatever you’d like by writing custom CSS code (just be sure to use a plugin for your CSS, like Simple Custom CSS available at wordpress.org).

    #3840
    Sophie Marteau
    Participant

    Hello Jenny, thanks for your answer. I don’t know if we talk about the same thing… Let me clarify myself

    When I write a post and that I want to add a content component (after having click on “add component”) you have 2 options: the first one is the selection of a background color for the content component and the second one is the selection of a color for the text of this same component. I don’t talk about the full content of the post but just the component text. So if I understand your comment right, you mean that we can’t use text and background color options for the content component, is that right? So it means that I can’t have a post with a content component with green background color, and another post with yellow background color?

    If it is so, I just don’t understand why you put these options if we can’t use them?

    Maybe I just don’t understood?

    Thanks in advance!
    Sophie.

    #3845
    Jenny @ Aesop
    Keymaster

    Hi Sophie.

    Yes, you are exactly correct. The Novella developer did not intend for the background color and text color options of the content component, quote component, etc, to do anything in Novella. I had added an enhancement request to our tracking system requesting that the options be removed from the editor (in Novella only) because it is misleading/confusing. The author’s intention with Novella was to create a breathtaking, uniformly styled theme where everything flows perfectly.

    If you want content components with different background colors, you can always write some custom CSS code. If you’re not familiar with how to use CSS inspector in Chrome, it’s super easy to use and will make finding the css classes that you’ll need when you want to change the design. Here’s a great in-depth article about this: https://www.html5rocks.com/en/tutorials/developertools/part1/

    Hope this helps!

    #4236
    Jenny @ Aesop
    Keymaster

    Hi Sophie. Just wanted to let you know that with Novella update 1.0.5, options that can’t be set (like content color, etc) will no longer appear in the Aesop component editor. Just visit your WordPress admin to update. If no update is available, be sure you have entered your Novella license at WPadmin –> Appearance –> Novella License.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.