Home Forums ASE Support Video Autoplay

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20497
    Airdres
    Participant

    Hi,

    I’ve been noticing that the video component no longer has the “autoplay” option.
    In the last article I wrote I used three videos, and I can’t seem to properly configure them as I’d like.

    I don’t like videos autoplaying, so I’ve always disabled that, but now the option is not present in the video component (they’re videos from YouTube by the way).

    I use the classic editor, in the text tab (as opposed to visual) the option autoplay=”off” still appears, and I set it to “off”, but the videos behaviour is weird… sometimes they autoplay, sometimes they don’t.

    How could I control the videos autoplay behaviour as it used to be? (is it something from the YouTube API?)

    Last article is: https://www.alpharamirez.com/en/little-violeta-tikon-tikon/

    Thanks a lot!

    #20516
    Hyun Supul
    Keymaster

    Hi,
    The problem was that Autoplay nowadays only works if the video is MUTED. This is something outside the control fo Aesop.

    So if you set the Mute option to ON, you should be able to access the autoplay options. Let me know if this helps.

    #20522
    Airdres
    Participant

    Hi Hyun,
    Indeed if I choose Mute ON I can access the autoplay options.

    My issue is that I didn’t want autoplay at all, so not choosing Mute ON shouldn’t have any impact I thought, the video wouldn’t autoplay as intended, and when somebody wanted to play it, it’d play with volume normally.

    The behaviour I was having was that it would for some reason autoplay randomly, even with volume.

    But I think I found a workaround.
    Editing on the text tab, the video component also has the following attributes: viewstart=”on” viewend=”on”.
    I just changed those to OFF, and then left the rest as I usually do, and now I’m getting exactly the behaviour I want.

    I don’t know what those do, but it made the trick apparently.

    So now my videos are mute=”off” autoplay=”off” viewstart=”off” viewend=”off” and I get exactly what I want. A video that’s just there, won’t autoplay, and when some viewer chooses to view it, it starts normally with volume. That had been the usual behaviour until this last change.
    Cheers!

    #20529
    Hyun Supul
    Keymaster

    Hi Andres,
    I released a new version that improves the behavior. (2.0.12) Autoplay should be off until you expelicitly turn it on. Hope this helps.

    #20533
    Airdres
    Participant

    Hi Hyun,

    I just replied because I hadn’t done anything with articles or videos up to this point.
    But I just embedded two videos in a new article without editing anything myself on the “text” tab, and the behaviour now is as I expected it to be. It seems you fixed it!

    Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.